PBR (Policy-Based Routing)
- PBR은 Routing table보다 우선하는 경로 정책을 생성하는 기능. 특정 출발지 IP 주소에 대해서 Next-hop을 변경할 수 있다.
- PBR을 구성하면 Router는 PBR을 우선적으로 확인한 후 PBR에 Match되는 경로가 없는 경우 Routing table을 확인한다.
목차
0. PBR 설정 전 확인
1. PBR 구성
2. PBR 확인
[구성도]
[초기 설정]
IOU1
interface Ethernet0/0
ip address 172.16.0.1 255.255.255.0
duplex auto
!
interface Serial2/0
ip address 172.16.2.1 255.255.255.252
serial restart-delay 0
!
interface Serial2/1
ip address 172.16.1.1 255.255.255.252
serial restart-delay 0
!
route-map PBR permit 1
match ip address 10
set ip next-hop 172.16.2.2
!
router ospf 1
network 172.16.0.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.3 area 0
network 172.16.2.0 0.0.0.3 area 0
!
IOU2
interface Ethernet0/0
ip address 172.16.3.1 255.255.255.0
duplex auto
!
interface Serial2/0
ip address 172.16.2.2 255.255.255.252
serial restart-delay 0
!
interface Serial2/1
ip address 172.16.1.2 255.255.255.252
serial restart-delay 0
!
router ospf 1
network 172.16.1.0 0.0.0.3 area 0
network 172.16.2.0 0.0.0.3 area 0
network 172.16.3.0 0.0.0.255 area 0
!
IOU3
interface Ethernet0/0
ip address 172.16.0.100 255.255.255.0
duplex auto
!
router ospf 1
network 172.16.0.0 0.0.0.255 area 0
!
IOU4
interface Ethernet0/0
ip address 172.16.3.100 255.255.255.0
duplex auto
!
router ospf 1
network 172.16.3.0 0.0.0.255 area 0
!
[PBR (Policy-Based Routing) 기초]
0. PBR 설정 전 확인
- IOU3(172.16.0.100) 에서 IOU4(172.16.3.100)으로 Traceroute를 걸어본다.
- 172.16.1.2를 Next-Hop으로 통신되었다.
- PBR 설정을 통하여, 우선 경로를 지정하도록 한다.
- IOU4으로 가기 위해서, 172.16.2.2 으로 우선적으로 경로를 지정한다.
1. PBR 구성
1.1) PBR 설정
- 다음과 같이 IOU1에서 설정한다.
access-list 10 permit host 172.16.0.100
!
route-map PBR permit 1
match ip address 10
set ip next-hop 172.16.2.2
exit
!
interface e0/0
ip policy route-map PBR
exit
!
1.2) PBR 설정 확인
- 설정 후, Interface Ethernet0/0에서 PBR route map이 설정된 것을 확인할 수 있다.
show route-map
- route-map의 설정을 확인할 수 있다.
- Route-map 적용 후 route-table에서 확인하면, 172.16.2.2로의 Next-hop 경로가 생성되었다.
2. PBR 확인
- 다시 한번 더, 172.16.3.100으로 Traceroute로 경로를 확인해본다.
- 위에서 설정한 PBR 설정이 정상적으로 적용되었다. Next-Hop이 172.16.2.2로 설정되어있다.
- IOU1에서 debug ip policy 으로 route map 상태를 확인가능하다.
'IT > ㄴ Cisco' 카테고리의 다른 글
[CISCO] IP SLA 기초 (IP Service Level Agreement) (0) | 2023.12.01 |
---|---|
[CISCO] VRF 기초 (Virtual Routing Forwarding) [ip vrf forwarding] (0) | 2023.08.24 |
[Cisco] GRE-Over-IPSec 알아보기 [crypto map과 ipsec profile 차이점 / GNS3 / Wireshark / ChatGPT] (0) | 2023.08.20 |
[CISCO] IPv6 기초 및 정리 (0) | 2023.08.20 |
[Cisco] GRE Protocol 알아보기 [GNS3 / Wireshark / ChatGPT] (0) | 2023.08.19 |